Nette Framework Requirements Checker

This script checks if your server and PHP configuration meets the requirements for running Nette Framework.

Congratulations! Server configuration meets the minimum requirements for Nette Framework.

Please see the warnings listed below.

Details

Web server nginx/1.10.0
PHP version 7.1.0-5+deb.sury.org~xenial+1
Memory limit 128M
.htaccess file protection
Function ini_set Enabled
Magic quotes Disabled
Register_globals Disabled
Zend.ze1_compatibility_mode Disabled
Variables_order Enabled
Reflection extension Enabled
Reflection phpDoc Enabled
SPL extension Enabled
PCRE extension Enabled
ICONV extension Enabled and works properly
Multibyte String extension Enabled
Multibyte String function overloading Disabled
Memcache extension Disabled
Memcache extension is absent. You will not be able to use Nette\Caching\MemcachedStorage.
GD extension Disabled
GD extension is absent. You will not be able to use Nette\Image.
Bundled GD extension Disabled
Bundled GD extension is absent. You will not be able to use some function as Nette\Image::filter() or Nette\Image::rotate().
ImageMagick library Disabled
ImageMagick server library is absent. You will not be able to use Nette\ImageMagick.
Fileinfo extension or mime_content_type() Enabled
HTTP extension Disabled
HTTP_HOST or SERVER_NAME Present
REQUEST_URI or ORIG_PATH_INFO Present
SCRIPT_FILENAME, SCRIPT_NAME, PHP_SELF Present
SERVER_ADDR or LOCAL_ADDR Present

Requirements Checker version 1.2